T-Mobile: Phone, text OK, but no internet

March 6, 2012

I’m currently in the US for a conference. Using my Australian cell phone while traveling is just asking for a HUGE bill, so I’ve purchased a T-Mobile pre-paid SIM with unlimited phone, unlimited text and data — all for just a couple of dollars a day.

I went to a T-Mobile store (Grapevine Mills Mall, TX), and the very helpful Robert got me sorted with the new SIM, getting it activated, and checking that it all worked. Phone worked – check; text worked – check; data worked – nope. He called the Support people and they said it should work within about two hours (something about ‘provisioning’). Data is the main reason I wanted a US SIM as I don’t make/receive a lot of calls/texts. Anyhow, about four hours later, I still couldn’t access the internet from my phone. I called Robert again (he’d told me to, if there were still problems), and after making a quick call, he suggested I call T-Mobile’s tech support as there were some settings I’d probably have to change on my phone to get the internet.

I got through to Travis in T-Mobile support and he was MOST helpful. As I couldn’t change the settings while I was talking to him on the phone, he called me back at my hotel and walked me through it all. All up, I guess I was on the phone with him for about 30 minutes and I never felt pressured or hurried.

It seems when you put in a SIM from another carrier, you have to change something called the APN settings. Who knew?

So for future reference for myself in case I use a T-Mobile SIM again when I’m in the US, here’s what I had to do on my unlocked Telstra Android phone (HTC Sensation) to get internet access:

  1. Settings > Wireless & Networks.
  2. Make sure WiFi is turned OFF.
  3. Select Mobile Networks (listed below Mobile Network).
  4. Turn Data Roaming ON.
  5. Make sure Enable Always-on mobile data is ON (it was for me, by default).
  6. Select Access Point Names (aka APN).
  7. Tap the menu icon and select New APN.
  8. Complete these details (NOTE: This is for T-Mobile only):
  9. Name: tmobile (or whatever name you want to give it that you’ll remember)
  10. APN: epc.tmobile.com
  11. Proxy:
  12. Port: 8080
  13. Leave the other settings as they are until you get to…
  14. MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  15. MMSC proxy:
  16. MMSC port: 8080
  17. Leave the remaining settings as they are.
  18. Tap the menu icon and then tap Save.
  19. Try opening something like Google.com — it worked for me!

Of course, when I get back to Australia and put in my Telstra SIM, I’m going to have to change that APN setting. Travis said all *should* need to do is select Reset to Default (at the Step 7 point above). Here’s hoping… otherwise I’ll have to talk to Telstra’s Support and previous experience tells me that this is NOT something I want to do. Telstra could learn a lot from T-Mobile in that regard.

See also:

Update: When I got back to Australia, I removed the T-Mobile SIM and replaced it with my Telstra SIM. The APN was automatically reset to the Telstra settings and I didn’t need to do anything! I could call, text and search the internet without changing anything. Nice.

[Link last checked March 2012]


  1. […] newsletter/blog of CyberText Consulting – technical communication specialists « T-Mobile: Phone, text OK, but no internet More internet woes… and solutions » Local connection only March 7, 2012 […]

  2. Tried this on my T-mobile Dart and fixed the problem!!! Thx

  3. Well done sir. Worked first time around.

  4. wow, this really helped me alot, I have a note 3 and was so disappointed after i could not get the internet to work.

  5. WoW … Thank you so much for writing this down and posting it …
    It worked great after months of “No Networks Available” … Thanks Again!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: