Captivate 5: First experiences of using Community Help

December 6, 2010

Adobe is using its AIR Help in Captivate 5. They call it Community Help and tout its wonders on their website (http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd101-7addec9711cd178cb3c-8000.html).

As a Help author, I was quite fascinated by AIR Help when I first saw it demonstrated at a conference a few years ago, so much so that I went along to a hands on session on it at the 2010 WritersUA Conference to learn more about it and how to create AIR Help (https://cybertext.wordpress.com/2010/03/24/writersua-2010-conference-day-2/).

However, the past week has seen me trying to use AIR Help as a user. And to say it’s frustrating would be an understatement! I was able to open and use it initially in Captivate 5, and I was able to change the search location to the local Help (see https://cybertext.wordpress.com/2010/11/29/captivate-5-change-the-help-options/), but since that first experience where I got a result, I’ve had nothing but grief from this Captivate 5 Help. And NO results for any search I try to do — it just ‘hangs’.

I’m finding it useless… not because what I want isn’t in there — it may well be — but because it seems to be trying to connect with the outside world all the time. My internet connection is not good, but it *is* broadband; however, I can’t seem to select the local Help from the Search Location as it’s forever trying to load up something. Task Manager tells me that the Help is using about 50 MB of CPU, but nothing works — I enter a term like ‘storyboard’ and get a blank screen and no drop-down options to change the Search Location to local Help. And I wait. And wait. And after about three minutes, I give up and try to close the Help. Sometimes it’ll close; sometimes I have to use Task Manager and kill the process to get the thing to close. (Update 16 December 2010: The Help is now fixed — see the end of this post for details.)

I just want to search the local Help! I DON’T want the Help to connect to the internet without me telling it too. Adobe must seem to assume that everyone in the world has a high speed, ‘always on’ internet connection. As a result, I CANNOT use the Help.

The only way I can find answers to questions I have about Captivate 5 at the moment is to use Google. At least that’s quick.

Remember, I’m a Help author by profession. I really want this AIR Help to work. I really want to see how cool it can be. I really want to promote this to my clients. I really want to have a great user experience with the Help. I’m prepared to spend time checking it out, and I’m prepared to spend some time waiting.

All I’ve had is a FAIL on every count. I can’t even get a result within three minutes when I enter a term…

No wonder ordinary users get frustrated and give up and say the Help is useless if they experience what I’ve been experiencing.

BTW, in case it makes any difference, I’m using Windows XP SP3, on a 4 GB RAM computer, with well over 250 GB free hard drive space, and an internet connection of around 2.5 Mbps. And I cleared the Captivate cache.

Further to this…

I tried signing in to my Adobe account via the Community Help window (Account > Sign In) in case that made any difference. I got a blank screen. 15 minutes later (yes, I timed it), I still had a blank screen, and I could only close the Help by killing the process in Task Manager.

Update 14 December 2010: I downloaded and installed the Captivate 5 update, then tested the Help again. Same story as above.

Update 16 December 2010: I was contacted by the Product Manager for Community Help who offered the suggestions below. I had to uninstall and reinstall the Community Help and now it’s back! Hope these suggestions help someone else who might have this issue:

Local search is dependent on the presence of a particular file (chcsearch.html) that is downloaded when a user first downloads the content. The best way to confirm is to check via the Help application’s Preferences UI.

  • On the Mac, open up the Help app, and then look in the OS menu (Adobe Help > Preferences).
  • On Windows, open up the Help app, and then look under Edit > Preferences (or hit Ctrl +K)

In the Preferences UI, you should see a Local Content tab on the left. You should then see “Using Captivate 5” listed in the main window with a status message. If it says, Current – great. If it says, Pending Download or Update available, please go ahead and update via the Update button on the bottom of the panel. In fact, it may be worth updating just to ensure that you have the latest version of the content and ensure that you have the necessary search file in place.

If this is not addressing your issue, it may be necessary to uninstall and then reinstall the Help app (i.e. just the AIR app, not Captivate itself) via the instructions outlined here: http://kb2.adobe.com/cps/842/cpsid_84215.html

See also:

[Links last checked December 2010]


  1. […] 16 December 2010: After experiencing some issues with the Help, I had to uninstall and reinstall it. The more recent version has got an option to only search for […]

  2. […] expressed my dissatisfaction with this default connected Help before, but it was in reference to Adobe’s Community Help. Microsoft is as bad. The problem with connected Help is that you usually get TOO much information […]

  3. CAn anyone help. Have Captivate 5. When inserting a button and want to make it an ímage button – my drop down box to select an image disappears off to the right and I cannot access it. It was fine the other day. I have tried restarting Captivate but no luck.

    Any ideas?

  4. […] to ‘the cloud’ before (the horrible ‘Community Help’ used in Captivate 5: https://cybertext.wordpress.com/2010/12/06/captivate-5-first-experiences-of-using-community-help/), but this situation of not even being able to choose whether to view the locally installed Help or […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: